Invoice emails to Microsoft 365 / Outlook bouncing

Incident Report for SortScape

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 21:41 AEST

Update

Microsoft 365 and Outlook emails are delivering again.

We're going through the emails that bounced during the outage and sending those now.

This was caused by a wider issue at our email provider. Details: https://status.twilio.com/incidents/r2gvsly2y5ty
Posted Aug 18, 2026 - 11:21 AEST

Update

We are continuing to investigate this issue.
Posted Aug 17, 2026 - 06:54 AEST

Update

At this stage, we're still waiting on Microsoft to unblock our invoice emails.
Posted Aug 15, 2026 - 21:26 AEST

Investigating

Microsoft is currently blocking some emails we send to Office 365 and Outlook addresses. Invoices still show as sent in SortScape, then bounce.

Gmail and most other providers are delivering as normal.

We've asked Microsoft to lift the block and will update this page when we hear back.

In the meantime, don't resend those invoices from SortScape — they'll bounce again. Open the invoice, download the PDF, and email it from your own mailbox. You can also send the customer the "view your bill online" link from the invoice.
Posted Aug 15, 2026 - 19:07 AEST
This incident affected: Application.